Random frame drops in overwatch

We’re equivalent eextremely dollar elevated through charity: water’s Water x Stream campaign—up to $500,000, while funds remain!

Sign Up


You watching: Random frame drops in overwatch

ArgentinaAustraliaAustriaBahrainBelgiumCanadaCzech RepublicDenmarkFinlandFranceGermanyHong KongHungaryIndiaIrelandIsraelItalyJapanKuwaitMexicoNetherlandsNew ZealandNorwayOmanPhilippinesPortugalQatarRomaniaSaudi ArabiaSingaporeSlovakiaSouth KoreaSpainSwedenThailandTurkeyUnited Arab EmiratesUnited KingdomUnited States

Light Mode




See more: Windows 10 Dial Up Problems, Problems Connecting Windows 10 With Dial Up

ArgentinaAustraliaAustriaBahrainBelgiumCanadaCzech RepublicDenmarkFinlandFranceGermanyHong KongHungaryIndiaIrelandIsraelItalyJapanKuwaitMexicoNetherlandsNew ZealandNorwayOmanPhilippinesPortugalQatarRomaniaSaudi ArabiaSingaporeSlovakiaSouth KoreaSpainSwedenThailandTurkeyUnited Arab EmiratesUnited KingdomUnited States

Light Mode




See more: Cortana Windows 10 No Sound, How To Enable Sounds For Cortana On Windows 10

*

So we bought COMPUTER components a couple of weeks ago to construct a gaming computer. Once we put whatever together tried playing Overwatch, favor 5-10 min into the game, the FPS will drop from 250 to 20-25. And the lagging begins. It does this for a 2-3 min and also then it"ll go ago to the original and also be normal. But then aobtain tbelow is the same drop in the FPS. I started by replacing the CPU, replacing the motherboard, obtaining two sticks of ram (2x4gb=8gb) instead of one 8gb stick and also still the exact same difficulty exists. I additionally have actually an added fan in tright here as well.

We updated vehicle drivers, checked all connection on motherboard, had actually no background applications running. But yet, it still drops. So we took out the GPU and tried it another construct and also it runs flawlessly. Literally just plugged the GPU in and began playing. No issues tbelow. The PSU was being provided in an additional computer system so we took it from tright here and also inserted it in this. I dont know is the PSU have the right to be the concern. But I am at lost right here. Any advice would be exceptionally helpful, thank you so much!

Here is a list of the parts

https://classiccomputers.info/user/Farazinator/saved/Z64XLk

Case: Corsair Carbide SPEC-04 Mid-Tower Gaming Case - Black and Grey - CC-9011109-WW

CPU cooler: Cooler Master Hyper 212 EVO RR-212E-20PK-R2 CPU Cooler with 120mm PWM Fan

GPU: EVGA GeForce GTX 1060 3GB GAMING, ACX 2.0 (Single Fan), 3GB GDDR5, DX12 OSD Support (PXOC) Graphics Cards 03G-P4-6160-KR

MOBO: GIGABYTE GA-B250M-Gaming 3 LGA1151 Intel B250 Micro ATX 2-Way CrossFire DDR4 USB 3.0 Ambient LED M.2 Smart Fan 5 Motherboard

RAM: Kingston HyperX FURY Babsence 8GB Kit (2x4GB) 2133MHz DDR4 Non-ECC CL14 DIMM Deskpeak Memory (HX421C14FBK2/8)