Net stop spooler access is denied

I"m having domajor wide issues via clients not being able to print due to print spooler sub system errors on start up. When I try to manually start the spooler it starts for a 2nd and also then stops. if i try with a command prompt I get "System error 5 has actually emerged Access denied"

Our print server is WS2K3, I"m in the process of structure a 2012 print server to relocation it.

You watching: Net stop spooler access is denied

I have actually trawled the forums and tried the following:

- after providing "everyone" accessibility to the magazine I delete files in the C:WindowsSystem32spoolprinters & motorists folders and also tried to install network printers.

- repairing the windows install

At first this concern influenced everyone yet Win xp users seem to have actually reextended. WIn7 users still have actually the issue.

cheers

Brad


Popular Topics in Windows 7
TEST YOUR SMARTS
Which of the following retains the indevelopment it's storing once the system power is turned off?
ROM CPU RAM GPU
Submit »
88% of IT pros acquired this ideal.
Challenge
*

×

15 Replies


· · ·
*

Chipotle
OP
AkDonKeys
This perchild is a proved skilled.
Verify your account to enable IT peers to see that you are a professional.
Mar 4, 2014 at 01:15 UTC

Did you fill the win 7 chauffeurs to the print server for each printer? Are the Success 7 equipments x64 and the Xp x86?


0
· · ·
*

Pimiento
OP
Brad9917 Mar 4, 2014 at 01:19 UTC

Hi 907Jon

I"ve acquired a mixture of x64 and x86 Win7 and also x86 Success xp. I have actually x64 and x86 drivers installed on the server for each printer. The Old print server has actually operated fine for years and also then last week clients started obtaining these sub spooler errors.

cheers

Brad


0
· · ·

Ghost Chili
OP
Thanks A.J. Stringham Mar 4, 2014 at 01:21 UTC

Brad9917 wrote:

Hi 907Jon

I"ve obtained a mixture of x64 and also x86 Win7 and x86 Victory xp. I have x64 and also x86 chauffeurs mounted on the server for each printer. The Old print server has actually worked fine for years and then last week clients began obtaining these sub spooler errors.

cheers

Brad

Do you by opportunity have a WSUS server setup?


0
· · ·

Ghold Chili
OP
Thanks A.J. Stringham Mar 4, 2014 at 01:21 UTC

Or have scheduled updays collection to run on your machines?


1
· · ·
Mace
OP
Rockn
This person is a verified skilled.
Verify your account to enable IT peers to check out that you are a professional.
Mar 4, 2014 at 01:29 UTC

If they are erected to usage a print server I am not sure why they would be having actually local spooler concerns as print obs need to be spooled on the server itself. Are these global print chauffeurs per chance? Check the print spooler on the server and also the folder spoolprinters on the server to check out if it is empty and also if the spooler is quit.

Have any type of printers been deleted recently?


1
· · ·
Pimiento
OP
Brad9917 Mar 4, 2014 at 01:29 UTC

We have actually WSUS but it"s not presently functioning. Our equipments are acquiring their updays from the net at existing which isn"t right.


0
· · ·
Pimiento
OP
Brad9917 Mar 4, 2014 at 01:33 UTC

print spooler on the server is running and I deserve to print test pperiods from the server to the printers. both folders have actually the documents meant.

A printer was deleted freshly as it was taken offline.

cheers


0
· · ·
Chipotle
OP
AkDonKeys
This person is a showed professional.
Verify your account to permit IT peers to view that you are a professional.
Mar 4, 2014 at 01:33 UTC

What kind of printers and also vehicle drivers are you using? We are a complete HP environment(for printers) and the generic HP drivers provided us all kinds of troubles as soon as we were making the adjust over. We were making use of certain vehicle drivers for XP and also installed generic for win 7. attempt this one one machine and see if it works

Open a command prompt with right-click and use the "Run as Administrator" alternative.

Use sfc to restore the correct variation of spoolsv.exe, "sfc /scannow".

Start the Spooler organization to confirm it works and also set it to begin automatically.

See more: Automatically Windows Powershell Opens On Its Own : Techsupport

Open a Windows Explorer with right-click and use the "Run as Administrator" option.

Navigate to the WindowsSystem32 folder, right-click spoolsv.exe and also select the properties alternative.

Tick the Read Only checkbox and also click OK.

Copy the spoolsv.exe file to the desktop computer for great measure.

Reboot.


1
· · ·
Thai Pepper
OP
Galen in Laguna Mar 4, 2014 at 01:33 UTC

net speak spooler

delete c:windowssystem32spoolchauffeurs folder (just drivers)

net start spooler

the folder will be redeveloped. If you are still having problems, I would certainly inspect that the print server is not handing dvery own bad motorists.

if it is handing down poor chauffeurs then delete the printers. if you cannot delete the printers, quickly begin the Spooler service and easily attempt to rerelocate the printer, you have actually about 2.5 seconds before spooler bombs out again (the printer will certainly then gray out and you cannot rerelocate, unless spooler is actually running)


1
· · ·
Pimiento
OP
Brad9917 Mar 4, 2014 at 01:35 UTC

We have a combined bag of printers here Sharp, HP, Brother.. All printers are utilizing the vehicle drivers for each particular version, no universal drivers here. I"ll run the sfc and also obtain ago to you.

cheers


0
· · ·
Ghost Chili
OP
Thanks A.J. Stringham Mar 4, 2014 at 01:51 UTC

It"s unmost likely driver worries leading to spooler worries. If it"s widespreview to a specific OS, it"s a lot of likely an update. See what windows updays have actually gone via and also view what you may have to roll earlier. 


1
· · ·
Pimiento
OP
Brad9917 Mar 4, 2014 at 02:01 UTC

Hi Galen 

Sorry mate I need to have stated that while the regional spooler isn"t running there are no printers visible to delete.

A.J - I"m thinking windows updays also. I"m simply structure a fresh win7 box so I can test it with no updates mounted.

907Jon - still running the sfc... fingers crossed :-)


0
· · ·
Ghold Chili
OP
Thanks A.J. Stringham Mar 4, 2014 at 05:49 UTC

Keep us posted. 


0
· · ·
Pimiento
OP
Brad9917 Mar 4, 2014 at 05:55 UTC

I think it"s a windows upday mixed via one of our Sharp MFC. The fresh build 7 machine is fine until I run updates and then it has the exact same problem. I tried reinstalling windows and also not installing the sharp MFC and I had the ability to install all updates and still install printers.

I"ll do some even more digging tomoz. Thanks so much for your assist guys! I"ll store you posted


0
· · ·
Ghold Chili
OP
Thanks A.J. Stringham Mar 4, 2014 at 06:16 UTC

Brad9917 wrote:

I think it"s a home windows upday mixed with one of our Sharp MFC. The fresh build 7 machine is fine until I run updates and then it has actually the same issue. I tried reinstalling home windows and not installing the sharp MFC and also I was able to install all updates and still install printers.

See more: Libusb0.Dll Is Missing Windows 10, Download Libusb0

I"ll perform some even more digging tomoz. Thanks so a lot for your help guys! I"ll keep you posted

It absolutely would appear you have narrowed dvery own what the issue is even if not the actual reason of it. Look at the updays that were run that led to it to stop functioning. Then just dig with each one"s KB (hopefully it"s just a few) and see if you have the right to gather any kind of clues. Just a thought.


1

This topic has actually been locked by an administrator and also is no longer open up for commenting.