Macintosh MacPaint
Limitation on Warranties and Liability
All implied warranties concerning this manual and media, including implied warranties of merchantability and fitness for a particular purpose, are limited in duration to ninety (90) days from the date of original retail purchase of this product.

Neither Apple nor its software suppliers make any warranty or representation, either express or implied, with respect to the software described in this manual, its quality, performance, merchantability, or fitness for any particular purpose. As a result, this software is sold “as is”: the purchaser assumes the entire risk as to its quality and performance.

In no event will Apple or its software suppliers be liable for direct, indirect, special, incidental, or consequential damages resulting from any defect in the software or manual, even if they have been advised of the possibility of such damages. In particular, they shall have no liability for any programs or data stored in or used with Apple products, including the costs of recovering or reproducing these programs or data.

The warranty and remedies set forth above are exclusive and in lieu of all others, oral or written, express or implied. No Apple dealer, agent, or employee is authorized to make any modification, extension, or addition to this warranty.

Some states do not allow the exclusion or limitation of implied warranties or liability for incidental or consequential damages, so the above limitation or exclusion may not apply to you. This warranty gives you specific legal rights, and you may also have other rights that vary from state to state.

Copyright
This manual and the software (computer programs) described in it are copyrighted by Apple or by Apple’s software suppliers, with all rights reserved. Under the copyright laws, this manual or the programs may not be copied, in whole or part, without written consent of Apple, except in the normal use of the software or to make a backup copy. This exception does not allow copies to be made for others, whether or not sold, but all of the material purchased (with all backup copies) may be sold, given, or loaned to another person. Under the law, copying includes translating into another language or format.

You may use the software on any computer owned by you but extra copies cannot be made for this purpose. For some products, a multiuse license may be purchased to allow the software to be used on more than one computer owned by the purchaser, including a shared-disk system. (Contact your authorized Apple dealer for information on multiuse licenses.)

©1983 Apple Computer, Inc.
20525 Mariani Avenue
Cupertino, California 95014
(408) 996-1010

Macintosh is a trademark licensed to Apple Computer, Inc.

Apple and the Apple Logo are registered trademarks of Apple Computer, Inc.

Written by Carol Kaehler of Apple Macintosh User Education. Designed by Clement Mok. Illustrated by Susan Kare.

Program by Bill Atkinson.

Simultaneously published in the USA and Canada.

Reorder Apple Product #M1501
## Contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>How to Use This Book</td>
<td>2</td>
</tr>
<tr>
<td>Learning MacPaint</td>
<td>3</td>
</tr>
<tr>
<td><strong>Using MacPaint</strong></td>
<td>9</td>
</tr>
<tr>
<td>Lines and Patterns</td>
<td>10</td>
</tr>
<tr>
<td>Text</td>
<td>11</td>
</tr>
<tr>
<td>Using the Paintbrush</td>
<td>12</td>
</tr>
<tr>
<td>Editing Patterns</td>
<td>13</td>
</tr>
<tr>
<td>Using the Entire Page</td>
<td>14</td>
</tr>
<tr>
<td>Shifting the Whole Picture on the Page</td>
<td>16</td>
</tr>
<tr>
<td>Filling In Areas</td>
<td>17</td>
</tr>
<tr>
<td>Selecting and Changing an Area</td>
<td>18</td>
</tr>
<tr>
<td>Cutting and Pasting</td>
<td>21</td>
</tr>
<tr>
<td>Four Ways to Erase</td>
<td>22</td>
</tr>
<tr>
<td>Detailed Drawing</td>
<td>24</td>
</tr>
<tr>
<td>Constraining</td>
<td>25</td>
</tr>
<tr>
<td>Using the File Menu to Handle Documents</td>
<td>26</td>
</tr>
<tr>
<td><strong>Reference</strong></td>
<td></td>
</tr>
<tr>
<td>Tools Summary</td>
<td>27</td>
</tr>
<tr>
<td>Shortcuts</td>
<td>28</td>
</tr>
<tr>
<td>Other Special Keys</td>
<td>32</td>
</tr>
</tbody>
</table>
How to Use This Book

The best way to learn MacPaint is to explore the drawing tools and patterns on your own. This is a book of hints to guide you in your exploration.

■ If you want a brief lesson on getting started with MacPaint, see "Learning MacPaint."

■ When you want to find out more about using the tools and the commands in the menus, flip through "Using MacPaint." (You don't have to read these pages in any particular order.)

■ For a brief description of each of the tools, see "Tools Summary."

If the Apple Macintosh™ computer is totally new to you, you might want to look first at Macintosh, the owner's guide. It teaches the basic techniques you'll use to create pictures with MacPaint—clicking, dragging, selecting information, and choosing commands from menus.
Chapter 1

Learning
MacPaint
How to begin:

- Insert the MacPaint disk.

- Open a MacPaint document by clicking the Paint disk icon and choosing Open from the File menu, then clicking the MacPaint icon and choosing Open again.

In a few seconds, the screen will look like this:

Menus with commands to choose from

Tools for drawing, adding text, moving the page under the window, and selecting

Close box

Pointer (takes different shapes, depending on what tool you’re using)

Current pattern

Patterns to use

Line and border widths (current width is checked)
In this book, the following symbols indicate specific actions.

means **click**: Position the pointer, then briefly press and release the mouse button.

means **drag**: Position the pointer, press and hold the mouse button while you move the mouse, then release the mouse button.
Start working on the document you opened.

- Click the paintbrush in the tool palette:

  ![Paintbrush Icon]

- Move the pointer to the drawing window. (The pointer becomes a black circle for you to draw with):

- Draw a curved line:

  ![Curved Line Drawing]

Whenever you want to make changes to something you’ve drawn, you first select it.

Here’s how:

- Click the selection rectangle in the tool palette:

  ![Selection Rectangle Icon]

- Then drag in the drawing window:

  ![Selection Drag]

As you drag, a dotted outline encloses your drawing.
Whatever is inside the dotted rectangle is selected and will be affected by any command you choose from the Edit menu.

Here's how to choose a command:

Press

```
<table>
<thead>
<tr>
<th>File</th>
<th>Edit</th>
<th>Goodies</th>
<th>Font</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Undo</td>
<td></td>
<td>Æ2</td>
</tr>
<tr>
<td></td>
<td>Cut</td>
<td></td>
<td>ÆH</td>
</tr>
<tr>
<td></td>
<td>Copy</td>
<td></td>
<td>ÆC</td>
</tr>
<tr>
<td></td>
<td>Paste</td>
<td></td>
<td>ÆV</td>
</tr>
<tr>
<td></td>
<td>Clear</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Invert</td>
<td></td>
<td>ÆE</td>
</tr>
<tr>
<td></td>
<td>Trace Edges</td>
<td></td>
<td>ÆE</td>
</tr>
<tr>
<td></td>
<td>Flip Horizontal</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Flip Vertical</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Rotate</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
```

Release

To see how you can cancel your last action:

- Choose Undo from the Edit menu.

To see one way to erase:

- Click the eraser in the tool palette.
  Then erase part of your drawing:
Add text to your drawing:

- Choose the following font and font size from menus:

<table>
<thead>
<tr>
<th>Font</th>
<th>Font Size</th>
</tr>
</thead>
<tbody>
<tr>
<td>Venice</td>
<td>9 point</td>
</tr>
<tr>
<td>London</td>
<td>12</td>
</tr>
<tr>
<td>Athens</td>
<td></td>
</tr>
<tr>
<td>Toronto</td>
<td>14</td>
</tr>
<tr>
<td>New York</td>
<td>18</td>
</tr>
<tr>
<td>Geneva</td>
<td></td>
</tr>
<tr>
<td></td>
<td>24</td>
</tr>
<tr>
<td></td>
<td>36</td>
</tr>
</tbody>
</table>

- Click 

- Click in the drawing window where you want the text. A blinking vertical bar marks the place where text will be inserted when you type. Use the Backspace key if you make a mistake. You can make changes to what you type until you click somewhere else.

- Type: Follow the yellow brick road.

Change the style of what you typed by choosing Outline from the Style menu:

<table>
<thead>
<tr>
<th>Style</th>
</tr>
</thead>
<tbody>
<tr>
<td>Plain</td>
</tr>
<tr>
<td>Bold</td>
</tr>
<tr>
<td>Italic</td>
</tr>
<tr>
<td>Underline</td>
</tr>
<tr>
<td>Outline</td>
</tr>
<tr>
<td>Shadow</td>
</tr>
</tbody>
</table>

Follow the yellow brick road.

Save your work on the disk:

- Choose Save from the File menu.

To print your MacPaint picture:

- Choose Print from the File menu.
Lines and Patterns

Click any pattern to make it the current pattern:

- lines
- filled shapes
- hollow shapes

Lines and hollow shapes are drawn in black.

You can draw them in the current pattern by holding down the Option key.

Filled shapes have a black border and are filled with the current pattern.

The border palette controls line and border width.

Current width is checked

No border on filled shapes

Line/border widths and space between repeating copies
You can add text anywhere in the drawing window.

- Click the text tool in the tool palette, then click where you want the text.

The blinking bar marks the insertion point, where text you type will appear.

- Choose fonts, font sizes, and styles from menus.

**Current choices are checked.**

**Font**

- Venice
- London
- Athens
- Toronto
- New York
- Geneva
- Monaco
- Chicago
- San Francisco

**Style**

- Plain \[ \texttt{\textcolor{black}{\textbf{\textbf{P}}}} \]
- Bold \[ \texttt{\textcolor{black}{\textbf{\textbf{B}}}} \]
- Italic \[ \texttt{\textcolor{black}{\textbf{\textbf{I}}}} \]
- Underline \[ \texttt{\textcolor{black}{\textbf{\textbf{U}}}} \]
- Outline \[ \texttt{\textcolor{black}{\textbf{\textbf{O}}}} \]
- Shadow \[ \texttt{\textcolor{black}{\textbf{\textbf{S}}}} \]
- Align Left \[ \texttt{\textcolor{black}{\textbf{\textbf{L}}}} \]

Best sizes for the current font are outlined:

**Font Size**

- 9 point
- 12
- 14
- 18
- 24
- 36
- 48
- 72

Font, font size, and style choices including alignment can be changed until you click somewhere else.

Once you’ve clicked somewhere else, the text becomes like a picture instead of text. You can no longer make new font or style choices for it, but you can select and move, copy, or alter it like any other image.

This text is **24 pt. New York, underlined and shadowed.**
Using the
Paintbrush

The paintbrush paints in the current pattern.

To change the shape of the brush:

- Choose **Brush Shape** from the **Goodies** menu.

To draw symmetrical shapes with the paintbrush:

- Choose **Brush Mirrors** from the **Goodies** menu.

The four possible mirrors appear as lines. Click the mirrors you want to use either singly or in combination.

To turn off mirroring:

- Choose **Brush Mirrors** from the **Goodies** menu. Then click **None**.
Editing Patterns

To create your own pattern, choose **Edit Pattern** from the **Goodies** menu to edit the current pattern. Or double-click any pattern in the palette.

Current pattern

- Click or drag through dots to change the pattern.
- Click **OK** to replace the old pattern with your new one.
- Click **Cancel** to keep the original pattern. Patterns you create are saved with the document.
Using the Entire Page

An entire MacPaint document is 8 x 10 inches. At any one time, you can see about a third of the document in the drawing window.

To move to another part of the document:

- Choose Show Page from the Goodies menu.

- Drag the dotted rectangle to position the window on any part of the document. Click OK.
To move the document under the drawing window a small distance:

- Drag in any direction.
Shifting the Whole Picture on the Page

Choose **Show Page** from the **Goodies** menu.

Press anywhere outside the dotted rectangle (even if the image is inside the rectangle), and drag the image in any direction.

- To return to another part of the page, move the rectangle, then click **OK**.

- To erase, drag the image off the page and click **OK**. (Erasing this way is not undoable.)
Filling In Areas

To fill an outlined area:

- Click the paint can and any pattern.
- Then position the end of the pouring paint in any outlined area you want to fill and click.

If an outline has gaps or holes,

the pouring paint "leaks" through.

- Choose **Undo** from the **Edit** menu. Fill in any holes in the outline.

You can also fill black areas or outlined text:

**parallel**

**parallel**

**SALT**

**ZEBRA**
Selecting and Changing an Area

Two tools, the selection rectangle and the lasso, are just for selecting areas to be changed.

- To move a selection:
  Position the pointer inside it and drag.

- To make one copy:
  Hold down the Option key while you drag the selection.

- Use the selection rectangle to select a rectangular area.
  (To reselect, first click anywhere outside the selection.)

- Use the lasso to select nonrectangular objects:

The lasso tightens up around the image.

You can start dragging when the pointer shape is an arrow.
To make repeating copies:
Hold down both the Option and the * keys while you drag the selection.
(Line width determines space between copies.)

To stretch a selection:
Hold down the * key while you drag the selection.

A selected area "floats" in its own plane, without altering what's under it, until you click outside the selection.
Compare how the selection rectangle and the lasso work.

Moving a selection:

Making repeating copies:
Cutting and Pasting

With cutting and pasting, you can move or copy pictures or text from one document to another (either a MacPaint document or one you create with a different application), or from one part of a document to a different part.

You can also cut and paste among MacPaint documents and desk accessories you choose from the Apple menu.

Select what you want to cut or copy. Use either the selection rectangle or the lasso.

Choose Cut or Copy from the Edit menu in MacPaint or any application you want to cut or copy from. The selection goes on the Clipboard.

Go to the part of this or any other document you want to move or copy the image to. Make a selection rectangle there. If there is no selection, MacPaint will paste into the middle of the window.

Choose Paste from the Edit menu.

If you're pasting into a MacPaint document, drag the rectangle to the position you want the image, and click outside the rectangle to paste the image into the new place.

You can also paste text from a desk accessory or another application. Hold down the * key while you drag the selection to rearrange the text to fit the selection rectangle.

You can also paste text from a desk accessory or another application. Hold down the * key and drag the selection. MacPaint rearranges the text to fit the selection rectangle.
Four Ways to Erase

Drag the eraser.

Double-click to erase the entire window.

Select an area.

Then choose Clear from the Edit menu or press the Backspace key.
To erase the entire document, choose **Show Page** from the **Goodies** menu.

Position the pointer outside the dotted rectangle (even if the image is inside the rectangle), and drag the image off the page.
Detailed Drawing

Select the area you want to see in detail.

Then choose FatBits from the Goodies menu.

Use the pencil to click individual dots or drag through a group of dots to change them from black to white or vice versa. Or use any tool in the tool palette.

Drag with the grabber to move the document under the window.

Choose FatBits to return to the previous view.
Constraining

Generally, the Shift key lets you limit drawing to horizontal or vertical (and sometimes 45°) lines.

- Click the tool you want to use.
- Hold down the Shift key while you use the tool in the drawing window:

To move the document only horizontally or vertically

To draw or erase only horizontally or vertically

To constrain the lines to 45° and 90° angles

To draw squares,

rounded squares,

and circles.

Use the Shift key with the Option and keys to constrain the movement vertically or horizontally while moving, making a single copy of, or making repeating copies of a selection. Stretching or shrinking a selection using the Shift and keys changes the size but keeps the original proportions.

In Show Page, using the Shift key allows only vertical or horizontal movement of the dotted rectangle or the image.

Grid in the Goodies menu is also a constraint. It allows drawing, typing, or moving a selection only along the lines of an invisible grid.
Tools Summary

Select nonrectangular images.

Select a rectangular area, including the background.

Move the document under the drawing window so you can use the entire 8 x 10-inch page.

Type text. Choose fonts, sizes, and styles from menus. Confirm choices by clicking.

New York 12pt.
New York 12pt. Bold
New York 12pt. Italic
New York 12pt. Underlined
Fill an outlined area with the current pattern.

Spraypaint with the current pattern.

Paint with the current pattern. Choose Brush Shape from Goodies menu.

Draw a thin line—black on white or white on black.

Thank You
Draw straight black lines. Border palette controls line width.

Erase where you drag. Double-click to erase the entire window.

Draw hollow rectangles or rectangles filled with the current pattern. Border palette controls line width.

Draw hollow ovals or ovals filled with the current pattern. Border palette controls line width.
Draw freehand black lines. Border palette controls line width.

Draw filled freehand shapes. MacPaint connects the ends of a freehand line and fills the shape with the current pattern. Border palette controls line width.

Draw hollow polygons. Click to turn a corner. Border palette controls line width.

Draw filled polygons. Click to turn a corner. Double-click or click again at the beginning to end and fill the polygon. Border palette controls line width.
Shortcuts

**Use these keys to:**

- `:`
  Undo the last action

- `Backspace`
  Erase the selection

**Double-click to:**

- `Select the entire drawing window`
- `Show page`
- `Choose a brush shape`
- `Enter and leave FatBits`
- `Erase the entire drawing window`
- `Edit the current pattern (or any double-clicked pattern)`

Other Special Keys

**Use these keys to:**

- `Option`
  Copy while dragging a selection

- `Use current pattern instead of black for lines and borders.
  Change the pointer to`
- `Stretch or shrink while dragging a selection`
- `Enter and leave FatBits at an exact spot by clicking in the drawing window with the pencil`
- `Let an underlying image show through when you paint over it`
- `Change font sizes using > or < keys`
- `Change fonts using a triple combination: Command, Shift, and > or <`
- `Make repeating copies while dragging a selection`
- `Shift`
  Constrain drawing or movement of image on a page (see "Constraining" for details)